0

I am hosting CiviCRM on a shared server with CPanel with latest CiviCRM and Wordpress versions. I have created cron jobs for all active crons using wget. e.g.

wget 'https://domain.org/wp-content/plugins/civicrm/civicrm/bin/cron.php?name=NAME&pass=PASS&key=KEY&job=cleanup'

Crons are running and the last run times on the scheduled job page are updated for my active jobs but the system status page lists the last time cron ran to be when I last ran all jobs manually.

Is there something else I should do?

1

You do not need to have a separate cronjob for each job: on the admin interface, set the frequency for each job you want to (nightly is good for most of them, but the one that process the mailing and handle the bounces are better run hourly or more frequently)

And then if you wget without the "job=cleanup" it will automatically try to process all the ones that you have enabled... and should properly log that they were processed

  • I set the run all jobs cron to once a day by removing the cron. Does the system status check to see that all jobs have been run using "run all jobs" once a day in order to keep status as okay? – themak Nov 2 '17 at 20:42
  • Did what you said - did one cron for all jobs once a day - other crons for other certain jobs that happen more often. System still says Crons are not running and lists the time the cron for all jobs last ran. – themak Nov 3 '17 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.