0

On civi 4.7.27 and wordpress 4.9

After recently upgrading both civi and wordpress I have noticed an issue that I have not been able to resolve. On the contribution pages, if I have Membership section enabled AND Contribution Amounts section enabled, everything works fine. If I have just Membership section enabled, everything work fine. However, if I have just the Contribution Amounts section enabled, after submitting the contribution, users will land on an error 500 page. The contribution will be completed and the record will be stored in civi,but the confirmation email will not be sent. After hours of trouble shooting I have narrowed it down to: this only happens when the Contribution Amounts section is enabled by itself. Everything was wirking fine, until the recent upgrades. The error logs I can find are not giving me any useful information.
Does anyone have any ideas?

Thank you.

  • can i check. are you using Real Time payment, or just/only Pay Later. There was a bug affecting Contribution pages that use only Pay Later. IF that is the issue then I will provide a proper answer with links – petednz - fuzion Dec 7 '17 at 21:36
  • It is an issue using both real time and pay later options. We actually do not use pay later at all. I just enabled it so I can live test after I discovered the issue. It will not work either way. If I disable Contribution Amounts and just use the Membership Section it will work, If use the Membership and the Contribution Amount Sections together, it will work, but if I enable only the Contribution Amount section, we get Error 500. – fdarn Dec 7 '17 at 23:05
  • can you replicate on demo? – petednz - fuzion Dec 8 '17 at 2:41
  • No I can't. i tried and it didn't work and I have several working contribution pages, but as soon as I disable membership and enable Contribution Amounts by itself, they don't work. Things I tried, disabled all plugins, rebuild a different contribution page, tried different profiles, different configurations. It all comes down to the same issue. – fdarn Dec 8 '17 at 3:20
1

Is there any suspicious info in CiviCRM or apache log? Can you try by applying https://github.com/civicrm/civicrm-core/pull/11454 patch works?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.