0

I am on Joomla version 3.8.2 with Php 7. I tried to upgrade to CiviCRM 4.7.28 but I received and error message (I didn't capture it) that it could not unzip the file because I have php 7. Unfortunately, I no longer have access to the administration panel as I am getting a blank screen.

These are the error messages:

Warning: require_once(CRM/Core/ClassLoader.php): failed to open stream: No such file or directory in /home/pastoral99/public_html/administrator/components/com_civicrm/civicrm.settings.php on line 462

Fatal error: require_once(): Failed opening required 'CRM/Core/ClassLoader.php' (include_path='.:/home/pastoral99/public_html/administrator/components/com_civicrm/civicrm:/home/pastoral99/public_html/administrator/components/com_civicrm/civicrm/packages:.:/opt/alt/php70/usr/share/pear') in /home/pastoral99/public_html/administrator/components/com_civicrm/civicrm.settings.php on line 462

Please HELP!

  • Hi @Tee, does the file /home/pastoral99/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/ClassLoader.php exist and is it readable by the apache server? – Kainuk - CiviCooP Dec 14 '17 at 12:35
  • Hi Kainuk, ClassLoader.php does not exist in this directory. Looks like some files were not installed during the upgrade. – Tee Strong Dec 14 '17 at 16:08
  • Looks you have found the solution, I wrap it up in an answer. – Kainuk - CiviCooP Dec 14 '17 at 18:23
  • i reread your comment and unzipping the file worked. i am now able to access my joomla admin area. i have many civicrm errors but ill try to figure those out and hopefully get it back up and running again. thanks for your help. – Tee Strong Dec 20 '17 at 10:30
1

Check if the file ClassLoader.php is on the file system. The location for Joomla is:

../administrator/components/com_ci‌vicrm/civicrm/CRM/Co‌​re/ClassLoader.php

Part of an upgrade procedure is to remove the old version and unpack the new version in the same place. If the unpacking fails the above error is shown.

Another reason for the same error can be the wrong value of $civicrm_root in the civicrm.settings.php file. More information in question Fails to open ClassLoader.php file .

  • Thanks for your help! Another question, since the failed installation is the culprit and likely the reason I can't access the Joomla administration panel, how can I reinstall outside of Joomla? – Tee Strong Dec 14 '17 at 23:27
  • I am not an expert on Joomla, but if you can try to unzip the Joomla installation files in the ../administrator/components/com_ci‌vicrm/civicrm directory. – Kainuk - CiviCooP Dec 16 '17 at 13:49
  • Actually, I need to install or uninstall and reinstall CiviCRM. The failed CiviCRM installation is preventing me from accessing the Joomla admin panel. – Tee Strong Dec 16 '17 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.