2

I'm experiencing, in the current Webform version (7.x-4.16), an issue reported fixed last year (issue #2612844). Anyone else experiencing it?

A date field with "Hide" checked for Day and Month (only interested in the year). The hint says "A hidden day or month will be set to 1." Instead getting errors for Month missing and Day missing upon form submission.

  • Just noting, since it is potentially misundertandable (by me!), the 'fix' is to the pure Webform module, and not the webform_civicrm module – petednz - fuzion Dec 17 '17 at 20:27
  • 1
    Good clarification petednz. I am experiencing the issue with CiviCRM processing "on" for the webform. The date field in the form is "wired" to set the end date of a CiviCRM relationship. All I'm interested in is the year, but this issue is forcing me to ask for a full date. Setting a default for the date doesn't help, once the year is changed the error manifests. I'm running version 7.x-4.19 of Webform CiviCRM Integration. – SRQ_civicrm Dec 18 '17 at 17:44
  • I expect this needs to be done as an 'improvement' to the webform_civicrm code - you might want to open an issue at drupal.org/project/webform_civicrm but it will probably require some effort/funding to get it added – petednz - fuzion Dec 18 '17 at 20:31
1

Yes I get this when I add a Relationship on a webform and set Day and Month to be hidden.

enter image description here

I expect this needs to be done as an 'improvement' to the webform_civicrm code - you might want to open an issue at drupal.org/project/webform_civicrm but it will probably require some effort/funding to get it added

  • 1
    Thanks for confirming. I created issue #2931633. Up-voted your answer but I don't have enough reputation for it to show! – SRQ_civicrm Dec 19 '17 at 1:50
  • well there is +1 for you ;-) – petednz - fuzion Dec 19 '17 at 5:35
  • 1
    Many thanks! I feel "official" now :-) – SRQ_civicrm Dec 20 '17 at 21:21
  • 1
    I can work around the problem now that I know it wasn't cockpit error. – SRQ_civicrm Dec 21 '17 at 14:06
  • 1
    Duh! Took me this long to figure out that upvoting and accepting an answer are two separate steps. – SRQ_civicrm Jan 20 '18 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.