3

I have a host running in a different time-zone from where I am operation and unless I set the website time zone to the hosting time zone I get the following error in CiviCRM:

Timestamps reported by MySQL (eg "2018-03-07 12:20") and PHP (eg "2018-03-07 11:20" ) are mismatched.

I know that my PHP time is correct, but how can I force the MySQL time to be set to my local time.

I've looked through the available answers but most of them advise setting the website timezone to match the host time, which is suboptimal

Is there anything that I can do to still be able to work in my time zone?

6

It turns out that if you are using Wordpress you need to set the timezone to specific location, e.g. London, rather than using the default UTC offset. When I used the London timezone the problem went away.

Configure this in WordPress at Settings > General /wp-admin/options-general.php

  • Thanks Marian, perfect answer for this trouble. – Ichi Sep 5 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.