1

Running Civi 4.7.27 / Drupal 7.59 + Webform Integration

I have Webforms to register Parent + Children and pay for an Event (the webforms are a bit complex, with lots of custom fields, but they used to work correctly).

Now, when I open the Webform second page (Contribution Page), I get the following message :

Notice : Undefined index: fee_amount in wf_crm_webform_postprocess->validateParticipants() (line 410 in /home/bapaparoisse/www/www/sites/all/modules/webform_civicrm/includes/wf_crm_webform_postprocess.inc).

However, everything seems to work correctly : the payment can be performed. Other such but simpler Webforms seem to work wiyhout this Notice.

I don't know when this began, since those events are passed now. I just know that I made some Extensions cleaning recently.

I will be glad if someone can bring me some light about this (where does it come from ?)

1

Given that is 'only' a Notice have you considered turning Notices off in the Drupal settings since it is normal practice to not display these on a production environment.

  • Thank you Pete, but it is also a way for me to detect errors in my configuration. BTW, is this message the sign of a configuration default ? – Jacques-Marie Moranne May 23 '18 at 8:54
  • I wouldn't know without one of our developers looking in to it. sorry can't help more. – petednz - fuzion May 23 '18 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.