3

Site running on PHP 7.2.18, FPM applicated server by nginx.

I have been having an issue with my Status & Connections page loading, i can't seem to figure it out.

My Error Logs show the following:

2019/05/21 11:11:11 [error] 16655#0: *8187 "/var/www/vhosts/test.co.uk/httpdocs/civicrm/a/index.html" is not found (2: No such file or directory), client: 69.323.48.14, server: test.co.uk, request: "GET /civicrm/a/ HTTP/2.0", host: "test.co.uk", referrer: "https://test.co.uk/civicrm/admin/extensions?reset=1"

All the other pages load correctly what i don't understand is why its looking for a index.html?

Thanks,

  • 1
    I'm not familiar with nginx but it might be an nginx configuration - what the error says is that it's actually doing a GET for /civicrm/a/, which is getting translated by the webserver to index.html, which is actually normal. So the problem is that somewhere before that it is somehow requesting /civicrm/a/ when you visit /civicrm/a/#/status, and I'm wondering if maybe nginx config is somehow doing that. – Demerit May 21 at 14:52
  • @Demerit - Thanks for taking your time to reply to me, its a weird one I can't seem to figure it out or find any resources online to help – Moe May 21 at 15:59
3

The issue was due to the fact i was using FPM applicated server by nginx instead of FPM applicated server by Apache.

I am not sure how to find a work around using NGINX but it is working now, thank you to everyone whos tried to help!

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.