2

Wordpress 5.0 Civi 5.14

UPDATE I am now convinced that the resource URL error is a real issue and not just a false positive. I just tried to add some component to the CKeditor. I saved it, I cleaned up the cache. The new components are not showing up on the ckeditor in the contribution pages. This is not an issue on my other clients civi installs, just this one.

Hello, I just finished a fresh install of Civi on a new site for a client.
I am getting the Alert that the Resource URL is incorrect. As far as I can tell, it is correct.

Also the contribution page url is showing incorrectly in the configurations. It is showing as: subdomain.mysite.org/?page=CiviCRM&q=civicrm%2Fcontribute%2Ftransact&reset=1&id=1

It should be: subdomain.mysite.org/civicrm?page=CiviCRM&q=civicrm%2Fcontribute%2Ftransact&reset=1&id=1

I think that might be a clue to the resource url problem, but I have been digging for hours and I can't find where to fix it.

See screenshots below.

enter image description here

enter image description here

enter image description here

****UPDATE TO SHOW civicrm.settings.php ***** enter image description here

3
+150

The alert is incorrect. As long as you are not having any other issues besides the alert, you can tell the alert not to remind you again.

In addition (now that I see the issue with Contribution pages - sorry I missed that), make sure you have the base page set under CMS settings in the CiviCRM administration settings.

enter image description here

In WP go to settings, Permalinks. Make sure that they are not set to Plain

enter image description here

Lastly make sure the base page is published. the page '/civicrm' is added on install enter image description here

  • Except they are having issues with the contribute page. And civicrm_root seems to work on wpmaster? – Demerit Jun 30 at 13:03
  • @KevinCristiano Thank you. I have installed Civi many times, and this alert not going away is a first for me, but I am seeing other posts about it being a false positive. However, I am still have the issue with the configuration page URL and I believe that might be related to resource URL issue. See the third screenshot. I hope that gives a clue to what path is not correct and where it is. it might help to point out that this subdomain didn't install in the public_html folder like I think it usually does. It installed outside that folder. Only the root domain has the public_html folder. – fdarn Jun 30 at 14:47
  • Demerit, I will look at wpmaster, I know that is a buildkit install and that does many things different than a manual install – Kevin Cristiano Jun 30 at 19:56
  • Thank you. Setting the WP Integration solved the problem with the contribution page URLs. The Incorrect Resource URL is still coming up and now it also say Cron is not running. But this solved the first part of the problem. I ll have to start another thread about Cron. – fdarn Jul 1 at 1:37
  • Thanks also @KevinCristiano. Note the cron will always warn if it hasn't run in the last hour (github.com/civicrm/civicrm-core/blob/5.14/CRM/Utils/Check/…) – Demerit Jul 1 at 2:05
1

Normally it's [civicrm.root]/. Is that screenshot just an example of values you've been playing with? Does it work with [civicrm.root]/?

And [civicrm.root]/ is what it is set to on https://wpmaster.demo.civicrm.org.

Also check your civicrm.settings.php file to see if it's overriding it for some reason.

  • Those are the values I am working with. It displayed that way after the install and that particular textarea is READ ONLY, so I can't change it to [civicrm.root]/. I just added another screenshot to show what my civicrm.settings.php file looks like. It appears to match what on the resource urls page. I would try adding [civicrm.root]/ there if it wasn't read only. – fdarn Jun 30 at 1:59
  • Ok, thanks. If you comment out or remove the line in civicrm.settings.php and then put [civicrm.root]/ in the field does that help? – Demerit Jun 30 at 2:40
  • I just tried. There was not a change – fdarn Jun 30 at 2:56
  • @Demerit in WP installs in oder to handle the multiple installation configurations we do not use [cicicrm_root] and put the proper paths in the civicrm.settings.php file. The alert is wrong. It has been for as long as it has been part of core and I disable on all WP sites. I have yet to find one where it works. – Kevin Cristiano Jun 30 at 12:59
  • @KevinCristiano I am wondering how to disable that alert. I decided it must be a false positive too. Do you have instructions on that? – fdarn Jul 1 at 1:47
1

I just had this problem on a Drupal installation and found a cause. In my situation, it was a false positive.

To check if the resource URL is correctly set CiviCRM tries to download the following picture from the server

https://<server>/sites/all/modules/civicrm/packages/jquery/css/images/arrow.png

It does the check, however, on the server itself, and that was protected by an IP firewall, that prevented browsing from the server. If you have SSH access you can check it with the following command:

curl https://<server>/sites/all/modules/civicrm/packages/jquery/css/images/arrow.png

0

I am on wp and the error I have (which is just a notice) is make the resource urls are portable. That's the false positive. I don't think the incorrect resource url error that you have is a false positive seems to be something wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.