0

I installed CiviCRM 4.7.31 in WordPress for one of my testing purpose. After i activating the CiviCRM plugin, CiviCRM is proving a blank interface. Can i why the menus are not appearing and how should i resolve it ?

CiviCRM Home

My currect PHP version is 7.2.24 and Wordpress version 5.4.1

These are the output of the console

Some cookies are misusing the recommended “sameSite“ attribute 4
This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. admin.php
The script from “http://localhost/wordpress/wp-admin/admin.php?page=CiviCRM&q=civicrm/ajax/l10n-js/en_US&r=iLhO1” was loaded even though its MIME type (“text/html”) is not a valid JavaScript MIME type.

SyntaxError: expected expression, got '<'

  • Welcome to SE! Just checking that you are aware that 4.7.31 is an old release. See civicrm.org/download for current releases. As regards the error, open your browser's developer tools then the network tab and see what content was actually returned. – Aidan Jun 3 at 12:54
0

Short answer: that third line from your console means your page is failing to load some javascript that it (probably) requires to display properly.

You might be able to test this theory by adding "&q=civicrm/admin" to your url and see if it shows something.

My best guess is that your civicrm 'assets' (css/js) aren't being loaded properly due to some base url settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.