0

On 4.6.4 I recently spotted a client where a Scheduled Reminder was be sent using From Address = 1 In the UI this was clearly correct ie it had the clients email in it. But they were arriving in inboxes from FIXME. Checking in the DB there is a Label field (which is all that is visible in the UI) and a Name field. Should the Name field be being updated to match the Label when one saves? If not is my system incorrectly using the Name rather than the Label when sending out emails? If not should the Name field be editable in the UI

7
  • see civicrm.stackexchange.com/q/3825/186 which might be related, fix ID'd is an upgrade to 4.6.4 Jul 10 '15 at 3:07
  • Thanks Joe - not sure it is related, but I should flag that my issue above was on 4.6.4
    – petednz - fuzion
    Jul 10 '15 at 6:08
  • peter yeah thanks never mind I need to learn to read. Jul 10 '15 at 13:16
  • I am also getting the FIXME display name when we send email from CiviRules and the Mail API. I looked in the database and could not find the table that has the From addresses. @petednz-fuzion or anyone, do you know which table it is? Thanks.
    – Larry K.
    Dec 15 '21 at 0:19
  • 1
    I converted your Answer to a comment, since an Answer it was not. From Emails are just an option field/value ie under Admin > System Settings > Option Groups or via /civicrm/admin/options?gid=31&reset=1
    – petednz - fuzion
    Dec 15 '21 at 2:30
2

When sending some emails, such as using CiviRules and the MailAPI extension, the display name of the specified from email address option is being read from the non-ui editable Name column, while the email address is read from the Label column. This results email being sent with the display name of FIXME when using the from email address that was created during the initial CiviCRM set-up. The Name of the first created email address is "FIXME" <info@example.com"> and is not editable via the user interface.

This record can be updated by editing option_group_id 31 value 1 in the database. An easier option might be to just create a new from address and delete or at least not use the original, and then make sure to update wherever that from address was used.

This behavior seems to be the result of two separate flaws, so I have submitted an issue to both the Core and MailAPI extension queues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.