0

I know I have contacts with no Country - this was something we came across recently when a colleague tried to use the proximity search and known contacts didn't appear. I've used Batch update to update a fair few I knew about, but when I use the Search Builder now to check for Contacts > Country > Primary > 'Is empty' or '≠' 'United Kingdom' and it comes back with nothing. But scrolling through the records, I can see there are still some records with no Country?

Am I not using the Search Builder properly or is there a bug? I'm using v4.4.13

  • Are there contacts that have a primary address with other fields filled in, e.g. street address, but no country? – davejenx Jul 21 '15 at 13:31
1

Try changing the search condition of the Search Builder ignore is_primary flag

look for: contact -> country -> home -> is not null (also change the address type) contact -> contact type = Individual

by this way you can select all the record with country field null also you can use batch update

  • Thanks for the answer. Tried different options using 'is not null' but it still showed all contacts in the results, not just the ones with an empty field. Just updated the version to 4.6 and now it's working... – Rose Lanigan Jul 22 '15 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.