I have an issue on v5.73.4 and could reproduce on CiviCRM Drupal Sandbox site.

I create a custom field set containing two select list fields (Committees and function in committee). Assign the custom field set to a contact subtype (eg: staff) the edit a staff contact. Adding the first entry works but adding additional entry to the contact looks as it works (shows the contact saved dialog) but the following entered values are never saved. So multiple values do not work anymore for custom field sets.

Another issue I noted is when you go back to the custom field set settings and remove the contact subtype (staff) to allow for any, you get the warning message saying you may loose data but the change is never saved. It keeps the contact subtype.

1 Answer 1


I tried to replicate the problem on dmaster. perhaps i didn't follow the set up you have, or there is a nuance i am missing but my testing worked for me.

if the records are still there (the site gets rebuilt each day) then you will see I made

enter image description here

and then add 2 sets of data (one at a time and refreshing the page in between) for that Contact https://dmaster.demo.civicrm.org/civicrm/contact/view?reset=1&cid=206 I got

enter image description here

Can you help narrow down the steps to replicate?

  • Thank you for investigating. I added two new fields with List Box to your custom field set and you are right it worked with the Display Style as Tab with Table selected as you did. But when changing the Display Style to Inline and then editing the contact it saves the first time but doesn't save the second and following fields entered. At least I found a temporary solution to my issue by changing the Display Style to Tab with Table on our production site. I hope you will have the time to check my changes before the demo site resets. Commented Jun 11 at 14:56
  • I still can't replicate (and no your example isn't still on the site. Here are my steps. Create set of fields for Contacts. Set to multi record (display = table), save data to 'demo' contact. Change settings of fields to Inline. Note the ? says this is not recommended. Go to Demo contact, use Edit, add a third set of data. Save. All looks good. Are you staying this is still specific to sub-types?
    – petednz - fuzion
    Commented Jun 11 at 19:30
  • REPLICATED. I tested with fields for sub-contact. not sure if that made the difference. but when using the EDIT button. although it shows the "Another staff multitest" option, (which inscreen editing doesn't) it does not save. Have raised at chat.civicrm.org/civicrm/pl/cxejhubor7bz9ne575srkm699o
    – petednz - fuzion
    Commented Jun 11 at 19:35
  • Thank you for helping and happy you could replicate :) As I said abos I will use the Tab with table until this is fixed in future release (even more if, as you stated, Inline is not recommended for multiple fields which I didn't noticed...I should click the ? more often.). Commented Jun 11 at 22:09
  • indeed there is a wealth of good pointers in those '?' help texts
    – petednz - fuzion
    Commented Jun 12 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.