1

I have installed CiviCRM successfully for WordPress. However, the Civi dashboard shows many 404 errors. My install directory is content/plugins/civicrm and the dashboard is searching for wp-content/plugins/civicrm. I am not able to find a setting that tells Civi where to look for the content directory. Is this something that I can modify?

3

I'm sorry to say that you'll have to revert back to the default 'wp-content' folder name in order to use CiviCRM. I can find at least 5 places in CiviCRM core where this is hard-coded.

  • 1
    I agree with Christian. I have been looking at this again recently as this is a blocker to many things. Christian, thoughts on trying to work together to remove these hard coded references? The problem I see is when CiviCRM runs a process that does not bootstrap wp. This had been the issue with the PayPal IPN, I am certain a few others are still out there. – Kevin Cristiano Aug 28 '15 at 13:39
  • Whilst the wpLoadPhp setting is a good start (and was sufficient to get Paypal IPN working) Civi-for-WP needs to be more sensitive to its context. There are a stack of other possible constants that WordPress uses to define its environment - as Corey's question demonstrates. And that's without raising the issue of Multisite. Kevin, I'd happily work on this with you during Edale, even if you're only present remotely ;-) – Christian Wach Aug 28 '15 at 18:49
  • Thank you for the reply. I have WP installed in a subdirectory with the content directory in the doc root. My solution has been to create a sym link named wp-content inside the WP subdirectory that points to my content directory. This is working for me (so far) without issue. – Corey Aug 30 '15 at 21:19
  • That's a neat workaround, thanks for sharing. – Christian Wach Sep 7 '15 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.