6

I upgraded two installations of CiviCRM 4.6.11 to 4.7 on the same server. Both upgraded fine, but now have the following errors:

1) Systems Settings --> CMS Database integration shows nothing (no paths or fields displayed). Normally I would expect at least a field to enter the Joomla Users Table name.

2) Systems Settings --> Directories shows this error:

<div id="crm-container" class="crm-container" lang="en" xml:lang="en"> <style type="text/css" media="screen"> 
@import url(http://domain.com/administrator/components/com_civicrm/civicrm/css/civicrm.css); 
@import url(http://domain.com/administrator/components/com_civicrm/civicrm/bower_components/font-awesome/css/font-awesome.min.css);
</style> <div class="messages status no-popup"> <i class="crm-i fa-exclamation-triangle crm-i-red"></i> 
<span class="status-fatal">Sorry but we are not able to provide this at the moment.</span> 
<div class="crm-section crm-error-message">Cannot resolve path using "cms.root.path"</div> 
<p><a href="http://domain.com/administrator/" title="Main Menu">Return to home page.</a></p> 
</div> </div> 
<script language="JavaScript"> function toggle( element ) { var parent = element.parentNode; var className = parent.className; if ( className == 'crm-accordion-wrapper collapsed crm-fatal-error-details-block') { parent.className = 'crm-accordion-wrapper crm-fatal-error-details-block'; } else { parent.className = 'crm-accordion-wrapper collapsed crm-fatal-error-details-block'; } } </script>



Anyone else seen anything like this? There are no php errors logged (but some warnings), and the CiviCRM log shows this:

$backTrace = #0 ...civicrm/CRM/Core/Error.php(444): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 ...civicrm/CRM/Core/Invoke.php(57): CRM_Core_Error::handleUnhandledException(Object(RuntimeException))
#2 ...civicrm.php(116): CRM_Core_Invoke::invoke((Array:4))
#3 ...civicrm.php(40): civicrm_invoke()
#4 ...CMS_root_directory.../libraries/cms/component/helper.php(392): require_once("...civicrm...")
#5 ...CMS_root_directory.../libraries/cms/component/helper.php(372): JComponentHelper::executeComponent("...CMS_root_directory.../administrator/components/com_civicrm/civicrm...")
#6 ...CMS_root_directory.../libraries/cms/application/administrator.php(98): JComponentHelper::renderComponent("com_civicrm")
#7 ...CMS_root_directory.../libraries/cms/application/administrator.php(152): JApplicationAdministrator->dispatch()
#8 ...CMS_root_directory.../libraries/cms/application/cms.php(252): JApplicationAdministrator->doExecute()
#9 ...CMS_root_directory.../administrator/index.php(47): JApplicationCms->execute()
#10 {main}
  • 1
    I got the same error (running on Joomla 3); also it appears that in some instances Civi generates a path where the /administrator piece is left out. In civicrm.settings.php the URL's are defined correctly both in /administrator/components/com_civicrm and /components/com_civicrm @Jern, were you able to resolve this? – MtnPavlas Feb 1 '16 at 8:52
  • 1
    No, I haven't found a solution. The settings files seems fine. I tried adding an override for the CMS root, but this made no difference. One other strange things is that the css isn't loading on the Directories page. It's displaying without the CiviCRM css. I wonder if it could be a problem with the pathname of the Civi css file. – Jern Feb 2 '16 at 10:48
  • I've seen the problem with Directories too running Joomla 3.x – Stephen Palmstrom Feb 4 '16 at 20:53
  • After similar upgrade on Joomla 3.4.8, I got a "cron not recorded" error. Cleared caches and reset paths, now completely broken. All blank pages, frontend and backend. Please advise. – BruceW Feb 5 '16 at 2:24
  • 1
    I'm also seeing trouble with cms.root, but by hacking administrator/components/com_civicrm/civicrm/templates/CRM/Admin/Form/Setting/Path.hlp to replace the first crmResPath with crmResURL my Directories page now loads.. I also note this in administrator/components/com_civicrm/civicrm/CRM/Extension/System.php:: // At time of writing, D6, D7, and WP support cmsRootPath() but J does not – eug Feb 12 '16 at 9:00
7

Thanks to eug for finding the problem (see comments). Eug's solution worked for me:

Edit the file administrator/components/com_civicrm/civicrm/templates/CRM/Admin/Form/Setting/Pa‌​th.hlp to replace the first crmResPath with crmResURL

Update: problem persists in 4.7.3. Have upgraded the bug report priority to Major.

Update: problem persists in 4.7.4.

Update: problem persists in 4.7.5.

Update: fix prepared for 4.7.6. See above bug report link for PR details.

Update: problem fixed in 4.7.6.

0

I updated Civicrm to 4.7.6 in a Joomla 3.5.1 site, with "System Status: Ok" reported as a result. However the reported fix was not there: CMS Database integration shows nothing (no paths or fields displayed) only two buttons.

I manually edited the file as in the answer Jern gave, and then the system reported a sync of users. Still no database-name for the Joomla users is displayed: no path or field. I tested the sync operation and it worked okay, so I guess the field is no longer necessary.

And reset it to the startsituation: my edit was not needed after all, see comment Jern below.

  • Exactly. The manual fix is not needed in 4.7.6, and you could/should reverse it. It is still confusing because there is now nothing to see on the CMS Database Integration page. The field "Joomla Users Table name" which was previously the only field on this page, has been intentionally removed from the Joomla version of 4.7.6 - see comment from Jitendra Purohit on this page: issues.civicrm.org/jira/browse/CRM-18058 – Jern Apr 23 '16 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.