1

Upgraded to 4.7 from 4.6.11 today. Importing contacts containing any value for State field results in an error for that field. Tried abbreviations and full values. Entering that info on a contact manually works OK though. I have since figured out how to import States, had to constrain the localization settings to the particular country I am importing, then change it over for each country - it's pretty tedious

Perhaps this has to do with another issue for Country list in localization (Contact Address fields-Selection Values). If I clear this field it populates United States after saving. Would like to include all countries in the list but can't make it stick. For a temporary workaround I have set to a single country (Australia) but that doesn't meet the requirements.

Attempting to run a contact report delivers the following warning message:

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /wp-content/plugins/civicrm/civicrm/packages/HTML/Common.php on line 144

there are a couple more lines to the error but they all refer back to the same line in common.php

  • To be certain: you did also add the Localization package to the upgrade? – Catorghans Feb 9 '16 at 11:50
  • No I didn't add the localization package. It wasn't needed for the previous two releases. Everything is in English. – Jambo Feb 9 '16 at 21:13
  • Do I need to add localization package to make all countries available? – Jambo Feb 10 '16 at 0:52
  • Please try, not sure, would not harm – Catorghans Feb 10 '16 at 7:37
  • I will try once I have setup another installation for testing purposes. By this logic however, US installations would need localization installed if they want to record contacts with addresses outside the US. Odd. – Jambo Feb 10 '16 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.