0

CiviCRM: 4.7.3 Joomla: 3.4.8 PHP: 5.5.45

None of my Membership Contribution confirmation emails are being sent. It doesn't matter if the person pays via PayPal, or is using Pay Later, they don't go out.

I receive the confirmation from PayPal that a membership fee payment has been made, but no other communications from CiviCRM, and I do have the email setup for CC to me.

Scheduled emails are being sent, as people are coming to the website to renew their memberships; and I've done the Outbound email check to verify that CiviCRM can send emails through the server.

This was working fine until August 2015, about the time I upgraded to 4.6.8 or so.

I kept up with the upgrades thinking that it was a fluke, but have not seen any corrections. I am not seeing any PHP errors, and I have been testing this using dummy names and a real email address to see if I can force any error messages.

I'm basically at a loss, and with a major event coming up, I need to have confirmations sent when people pay. I haven't tested with event confirmations yet, but that's the next step.

UPDATE: Just tested with events, and Confirmation emails are being sent to the attendee, and the treasurer so, at least for PayLater, the confirmations are going out for events.

UPDATE - 2016-03-18 upgraded to 4.7.4, and had to revert out of it as it broke the 'pay later' display as described in CRM-18118.

Installed the patch to CRM/Contribute/Form/Contribution/Main.php as shown in 18118, and also patched CRM/Contribute/Form/Contribution/Confirm.php as showin in 18118.

The live page shows the Pay Later, and when tested sent an email to confirm the renewal, and show an invoice. The CC email copies were sent properly. I am not going to reinstall 4.7.4 as it appears something else in that release broke the fixes in 18118.

  • We have same problem on Civi 4.7.2 Joomla! 3.4.8 paypal standard Event log indicates that civi recieves the payment, registers it, then starts constructing the event confirmation email. It hangs when trying to collect te profile information. #1 /data/htdocs/badministrator/components/com_civicrm/civicrm/CRM/Core/BAO/UFGroup.php(368): CRM_Core_Error::fatal("The requested Profile (gid=50) is disabled OR it is not configured to be used...") #2 /data/htdocs/badministrator/components/com_civicrm/civicrm/CRM/Event/BAO/Event.php(1295): CRM_ – Dave Florence Mar 15 '16 at 20:28
1

UPDATE - 2016-04-05 - OK ... the patch I installed from CRM-18245 appeared to take care of the issue with manual renewals from the website. I received a copy of the Paid Invoice, along with the email from PayPal acknowledging the payment.

So the final issue now is what is happening with Auto-Renewal Memberships? Are they supposed to be acknowledged by the system, and a receipt issued to the member??

Based on the fact that on April 4th I received a PayPal notice of payment, but no other notice of an Auto-Renewal, I suspect that area is not working correctly.

0

If you have customised any of the System Workflow Messages (right Tab at /civicrm/admin/messageTemplates?reset=1), then I suggest you Edit, copy all your txt and html, then save externally. Then return to previous screen and 'Revert to Default' and confirm if your notifications go out. If they do, then there is an issue with your Edited version, which may be something that needed looking at during an upgrade. M

Most often upgrades will spit out a 'and by the way the System Workflow Messages for x or y have changed and you will need to ensure any edited messages are corrected' type message.

HTH

  • I thought of that and reset all those messages, no help. – Neil Z Mar 10 '16 at 3:20
  • Evidently I'm the only person having this issue. I've reset all the system email messages to default. I've tested whether CiviCRM can send mail, and that test works. I've been able to send out mass emails which contain our newsletter as an attachment, but its not sending out any confirmation emails. Is there anything else I should be looking at? Is there a setting, a database trigger, anything that I should check to see if the system configuration and settings are correct?? . This is really starting to cause an issue. Thanks – Neil Z Mar 14 '16 at 19:48
  • Can you look in the mail log and confirm if they are getting that far? – petednz - fuzion Mar 15 '16 at 2:34
  • If you're talking about the server mail logs, I don't have access to them to check. I'm seeing the same error as Dave Florence is reporting above. – Neil Z Mar 16 '16 at 19:37
0

Check the logs at /media/civicrm/ConfigAndLog shortly after a payment has been made but no confirmation sent.

If you see something like the below, the issue is that Civi cannot access the information that was entered in the profile.

I'm having similar problem

Mar 15 19:13:18 [info] Contribution record updated successfully

Mar 15 19:13:18 [info] $Fatal Error Details = Array ( [message] => The requested Profile (gid=XXXXX) is disabled OR it is not configured to be used for 'Profile' listings in its Settings OR there is no Profile with that ID OR you do not have permission to access this profile. Please contact the site administrator if you need assistance. [code] => )

  • I'm seeing that error, but I've not changed the usage on any of the profiles. I still verified the settings, and they are correct. I've also checked the ACL permissions, and they are correct. – Neil Z Mar 16 '16 at 19:06
0

UPDATE 2016-04-01 I just did a clean re-install of 4.7.4 on the site. The confirmation emails are being sent properly now when the Pay Later option is selected, however, none are being sent when using PayPal.

Again, the only notice I get is the PayPal sent notice. I know the emails are going out for Pay Later as I received one yesterday. When I tested a live renewal today, again, only a PayPal receipt showed up.

The logfile shows this for the renewal.


Apr 01 06:50:21  [info] Contribution record updated successfully

Apr 01 06:50:22 [info] $Fatal Error Details = Array ( [message] => The requested Profile (gid=10) is disabled OR it is not configured to be used for 'Profile' listings in its Settings OR there is no Profile with that ID OR you do not have permission to access this profile. Please contact the site administrator if you need assistance. [code] => )

Apr 01 06:50:22 [info] $backTrace = #0 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Error.php(366): CRM_Core_Error::backtrace("backTrace", TRUE)

1 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/BAO/UFGroup.php(368): CRM_Core_Error::fatal("The requested Profile (gid=10) is disabled OR it is not configured to be used...")

2 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Contribute/BAO/ContributionPage.php(499): CRM_Core_BAO_UFGroup::getFields("10", FALSE, 4, NULL, NULL, FALSE, NULL, FALSE, NULL, 4, NULL)

3 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Contribute/BAO/ContributionPage.php(336): CRM_Contribute_BAO_ContributionPage::getProfileNameAndFields("10", "193", (Array:0))

4 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Contribute/BAO/Contribution.php(2524): CRM_Contribute_BAO_ContributionPage::sendMail("193", (Array:37), FALSE, FALSE)

5 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Contribute/BAO/Contribution.php(4626): CRM_Contribute_BAO_Contribution->composeMessageArray((Array:31), (Array:11), (Array:37), FALSE, FALSE)

6 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Contribute/BAO/Contribution.php(4575): CRM_Contribute_BAO_Contribution::sendMail((Array:31), (Array:11), Object(CRM_Contribute_BAO_Contribution), (Array:37), FALSE, FALSE)

7 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Payment/BaseIPN.php(450): CRM_Contribute_BAO_Contribution::completeOrder((Array:31), (Array:11), (Array:7), Object(CRM_Core_Transaction), FALSE, Object(CRM_Contribute_BAO_Contribution), FALSE, FALSE)

8 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Payment/PayPalIPN.php(290): CRM_Core_Payment_BaseIPN->completeTransaction((Array:31), (Array:11), (Array:7), Object(CRM_Core_Transaction), FALSE)

9 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Payment/PayPalIPN.php(343): CRM_Core_Payment_PayPalIPN->single((Array:31), (Array:11), (Array:7), FALSE, FALSE)

10 /home/nwtaadmin/public_html/administrator/components/com_civicrm/civicrm/extern/ipn.php(55): CRM_Core_Payment_PayPalIPN->main()

11 {main}


I verified that the profile in question is configured for profiles, it is NOT disabled, and the user is authorized to access the profile. As I mentioned the PayPal confirmations stopped around 4.6.8

This looks like the same issue as described in this bug report:

https://issues.civicrm.org/jira/browse/CRM-18245

  • Added the patch as listed in CRM-18245, tested it and I received a receipt for PayPal processed renewal. The log has this entry: Apr 01 08:06:33 [info] Contribution record updated successfully Apr 01 08:06:34 [info] Receipt sent Apr 01 08:06:34 [info] Success: Database updated – Neil Z Apr 1 '16 at 15:22
  • However, four days later, I get a PayPal notice of a membership renewal, no receipt sent. Check the Civicrm log, I see: Contribution Record updated, Database Updated, but no receipt sent. Back to the drawing board. – Neil Z Apr 4 '16 at 12:05
  • UPDATE - 10 minutes later - this was on a recurring payment. Need to see if there's a setting on these I missed, but I would think a receipt would be automatically sent. – Neil Z Apr 4 '16 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.