0

neither - for the directories

  • /home/mysite/public_html/wp-content/plugins/files/civicrm/custom_ext

nor - for the resources

works as an entry to find the extensions - everything is 775 permissions

Is anything in the path incorrect?

oddly, if I only use /home/mysite/public_html/ and /http://www.mysite.org/ civicrm picks up a zip file for another web app and displays this ridiculously long path to get to the file - in case you are interested it's

- Local Path = /home/mysite/public_html/qdpm/core/lib/vendor/symfony/test/unit/plugin/fixtures/http/pear.example.com/REST/p/sffooplugin

How it can find and interpret this as and extension and not the recommended path I don't know. Does anyone?

I have searched the forum and not found anything that worked. Not sure why this is so difficult to setup. I have many web apps that just create the directories you need and you are done.

Anyway, do I need to edit directories.php etc. to make this Extensions show up as they should. This is a deal breaker since there is no ad hoc reporting and I am hoping a report extension will give us what we need. Otherwise Civicrm is useless for us.

Thx

  • Do you have a slash in front of the URL on the resources? Also, have you created that directory if it doesn't exist yet? – Laryn - CEDC.org May 7 '16 at 1:56
  • I copied it from the field, it is as listed above with slash - when there is no directory, for one, you get and error, the directory is coreated – user3272 May 7 '16 at 16:10
  • Can you try opening the Developer Tools (F12 on most web browsers) and check the network tab for 404 errors? If so, can you please update this question with the URLs that CiviCRM shows? Given the random zip file issue, I wonder if there's an issue with the PHP or path configuration. Do you control the server, or is this a shared host? – Jon G - Megaphone Tech May 10 '16 at 4:53
  • Did you ever solve this problem? If so, could you please post an answer to the question below? – Jon G - Megaphone Tech Aug 6 '16 at 22:29
1

You can define a directory for your extensions and point CiviCRM to it. Remember that custom extensions directory should be kept outside your CiviCRM installation because they will be easy to manage in case you need an upgrade on your install.

Below are the steps which i propose you carry out to setup your extensions directory

  • create your directory probably /home/../../../extensions

  • Give appropriate permissions to your extensions directory

  • Go to your CiviCRM install, under administer >> System settings click on Resource URL.

  • place the full path of the directory you created above in the "Extension Resource URL"

  • Now any extensions you place in the directory above should be seen and interpreted properly as an extension

-* you can verify and install by navigating to Administer >> System settings >> Extensions( there you will see all extensions )

If that does not make sense to you then you can follow from Extensions

  • Now any extensions you place in the directory above should be seen and interpreted properly as an extension - they are NOT SEEN this is the problem is there a dev that understands why it can grab a totally unrelated zip file just fine and not its own as listed above? – user3272 May 9 '16 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.