1

I can't currently upload images into Civi emails - when I click 'send to server' nothing happens, and I can't view the server to browse previously uploaded images either. Have tried various web browsers but each new browser only works temporarily. Any ideas? Thanks.

  • 1
    Welcome to StackExchange. It would be helpful if you could edit your question to include your CiviCRM version and the CMS you are using (e.g. Drupal, WordPress or Joomla). – William Mortada Dec 20 '16 at 13:51
  • Have you checked the file permissions on the upload folder on the server? – William Mortada Dec 20 '16 at 13:56
3

The most common cause of that symptom in recents releases is due to a security enhancement in an updated version of the wysiwyg editor that is bundled with CiviCRM, that disallows symlinks.

If that is the issue, you can generally fix it by updating the corresponding path in http://example.org/civicrm/admin/setting/path?reset=1 to its non-symlinked version.

If that's not the issue, then reviewing the path and url settings might shed some light on the problem. And if none of that gives you a quick solution, I'd recommend looking at your server logs which should be instructive (either the civicrm log and/or your web service [apache/etc] log)

You might also want to review similar posts here:

  • This answer addresses not being able to "send to server." I only have the second problem. I can "send to server" and get the images in whatever I'm editing, but when I click on "Browse Server" then a window pops up with title "KCfinder: /files" (approx. from memory) and it never loads. Eventually it times out and I have to kill it. I can "browse server" on Wordpress pages, but I presume that's a completely different set of files and images that are uploaded for WP only. – Karl Rudnick Dec 21 '16 at 22:19
  • And we are running Wordpress 4.6.1 + CiviCRM 4.7.14 (latest) – Karl Rudnick Dec 22 '16 at 3:22
  • Sounds like your paths/urls are sending the images to a directory that can't be accessed. The slow/never load smells like a network timeout, I wonder if you've got an issue with base domain of the urls that are being used? Is it consistent? – Alan Dixon Dec 23 '16 at 18:37
  • I just wonder if it has anything to do with our adding an SSL cert after working on our site for a couple months. I changed one setting: Administer > System Settings > Resource URLs and check Yes on "Force Secure URLs (SSL)" . – Karl Rudnick Dec 24 '16 at 6:47
  • Make sure you go into your civicrm.settings.php file and update your CIVICRM_UF_BASEURL A lot of urls get generated based on the current url, but some use this baseurl and your browser won't want to load non-http images on an https page. – Alan Dixon Jan 2 '17 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.