1

I'm trying to set up a new CiviCRM install (4.7.24 plus Drupal 7.56) on a subdomain but I keep getting an error message.

I tried to install using the Drupal 'add a module' but after about a minute it just brings up a blank screen, and when I check the files online, nothing has been uploaded.

Then I tried to (slowly) ftp the files, but then when I run .../sites/all/modules/civicrm/install/index.php I get an error message along the lines of:

Warning: CRM_Core_ClassLoader::require_once(./vendor/autoload.php) [crm-core-classloader.require-once]: failed to open stream: No such file or directory in /var/sites/t//public_html/sites/all/modules/civicrm/CRM/Core/ClassLoader.php on line 107

Fatal error: CRM_Core_ClassLoader::require_once() [function.require]: Failed opening required './vendor/autoload.php' (include_path='.:/usr/local/lib/php') in /var/sites/t//public_html/sites/all/modules/civicrm/CRM/Core/ClassLoader.php on line 107

I'm not sure what I'm missing - is it because I'm installing on a subdomain? Can I get around this?

1

I think I may have found the cause? I've just noticed under the Drupal modules list a message to say the PHP version is insufficient (see screenshot). I presume this would hinder the install.

enter image description here

  • Just to confirm, updated the PHP and then everything installed without a hitch. – Rose Lanigan Sep 22 '17 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.