1

I have just updated my Joomla 3.19.8 site from version 5.18.12 to version 5.25.0, and my profile views are no longer including any custom fields.

No custom fields appear: - on any profiles displayed on the front end site - in the "Preview (all fields)" display in the backend Custom Profile - in the "Use create mode" display in the backend Custom Profile These profile views all load, but only default fields are displayed.

What I've Checked:

All custom fields show appropriately on their contact editing views inside Civi, and I can edit them no problem.

Under Custom Data all the field sets are visible, and all are set to "active" and "public".

Under Custom Profiles show all the custom fields are still in place for each profile, and all are set to "Expose publicly and for listings".

The ACL permission "Allow access to custom data" is set to "Allowed" for all user groups.

Any idea what update could suddenly cut off my profiles' access to the custom field sets? Or is there something else I haven't checked?

  • 2
    are you on php 7.3? – Pradeep Nayak May 22 at 18:21
  • i feel i have seen the same issue reported for WP sites too – petednz - fuzion May 22 at 20:02
  • We are on 7.2. I can update to 7.3 and see if it helps the problem. – minbori May 23 at 8:50
  • 1
    Thank you Pradeep! That was the issue. Switching to PHP 7.3 corrected it! Been banging my head against that one for hours :-D – minbori May 23 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.