2

I recently upgraded to vesion 4.7.3 (I'm running under Wordpress), and for some reason the TCPDF package was missing!

This led to the error: "Warning: opendir(/nhldata/631/106631/data/web/predigerforum/htdocs/wordpress/wp-content/plugins/civicrm/civicrm//packages/tcpdf/fonts/): failed to open dir: No such file or directory in /nhldata/631/106631/data/web/predigerforum/htdocs/wordpress/wp-content/plugins/civicrm/civicrm/vendor/tecnickcom/tcpdf/tcpdf.php on line 4148 TCPDF ERROR: Could not include font definition file: helvetica"

...when trying to create labels. I copied the directory "tcpdf" from the previous version into the packages directory and it seems to be OK now.

Perhaps there is a slip up in V 4.7.3, because I did nothing more than the normal upgrade process.

5
  • Still missing in 4.7.7 ;-( As before, I simply did a standard upgrade. May 7, 2016 at 11:27
  • I can confirm the same issue is in 4.6.16 version for Drupal. The 4.6.12 had those files so copying the civicrm/packages/tdpdf/ folder (from an older version of CiviCRM or a backup before the upgrade) to the newly upgraded CiviCRM solves the problem
    – Kasia W
    May 31, 2016 at 19:22
  • Still missing in 4.7.8 ;-( As before, I simply did a standard upgrade. Jun 4, 2016 at 15:13
  • Have opened an issue @ CRM-18755: TCPDF uses incorrect font path after upgrade. If your site is affected by this, maybe hit us up on chat.civicrm.org so we can debug a bit better :) Jun 5, 2016 at 15:24
  • Please see comment below. Cheers, David Jun 6, 2016 at 20:05

1 Answer 1

2

In 4.7.3 the TCPDF package was moved to civicrm/vendor/tecnickcom from civicrm//packages/tcpdf.

I just tested on a WP 4.5.2 and CiviCRM 4.7.8 install and was able to create mailing labels.

Can you give us the steps to reproduce? This may be a bug that needs an issue filed at https://issues.civicrm.org

One additional thought - try and empty the caches in WP the url is https://yourdomain.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/setting/updateConfigBackend&reset=1

2
  • I realised when I saw this that I had added a variable setting in the past to ensure that CiviCRM could find the font files: this correction is of course now wrong. Obviously, I had missed the change in package positioning - was this ever announced? Jun 6, 2016 at 19:53
  • I realised when I saw this that I had added a change in the past to ensure that CiviCRM could find the font files: this correction is of course now wrong. Obviously, I missed the package positioning change in 4.7.3: was this ever announced? If I remove that change, then things work correctly again for me. I had marked my change: "Force TCPDF to work when open basedir is enforced - see CiviCRM Jira CRM-14345", and I had to override 'K_PATH_MAIN' with '$civicrm_root . '/packages/tcpdf/' and 'K_PATH_IMAGES' with '$civicrm_root . '/packages/tcpdf/include/'. So please link new Jira with CRM-14345 Jun 6, 2016 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.