3

I do not have a web development background, so you will have to bear with me. I am currently using CiviCRM 4.7.0 on Wordpress 4.9.2. I am trying to set up CiviMail and am receiving a "Mail Not Sent" error. We are currently using Webfactional to host our Wordpress site. I had previously been receiving a softfail when using mail(). This is the softfail that I would see in "Show Original" on Gmail:

Received-SPF: softfail (google.com: domain of transitioning our email does not designate 74.55.86.74 as permitted sender) client-ip=74.55.86.74; Authentication-Results: mx.google.com; spf=softfail (google.com: domain of transitioning our email does not designate 74.55.86.74 as permitted sender) smtp.mailfrom=our email

I contacted them and followed instructions to set it up so that our Email would not be using their smtp but rather, go through Google Apps since Webfactional sets limitations on bulk mailings. I also set up an SFP DNS following their instructions for Google Apps. Following the instructions on Google Apps, I entered the following and received this error message when I tried a test email: enter image description here

I tried removing the ssl:// and also tried to use Port 25 just for the sake of testing. I don't quite know where to head from here. What steps did I just completely miss or do wrong that I'm not seeing?

Thanks in advance!

  • Did you try port 587? Also are you sure you've not exceeded your daily limit - support.google.com/a/answer/166852?hl=en – Sanjay Jain Apr 8 '16 at 17:55
  • Yes and yes, as I have not tried to send any emails outside of the test ones. Thank you for your reply. Xavier's answer below is what I was afraid of. – envirokid Apr 9 '16 at 20:41
3

you have a problem outside of civicrm realm: you are trying to send an email from a domain name that has a SPF record that doesn't include your server IP address.

it is the domain that you have set up for the bounce that needs to have the SPF record.

However, before you go down that rabbit hole: google has limitations on how many emails you can sent via their smtp server. It will never work for a production configuration as soon as you have more than a handful of contacts you want to mail.

I would suggest you to use an external provider to do the mailing (they are lots of providers (civismtp, sendgrid, mailjet...) that can easily be integrated with your civicrm that you can use.

0

I have used SMTP using gmail but i am not sure about using a different username other than gmail but you can try the below

First make sure you have set up the FROM Email ID - correctly

  • Set the FROM Email Address

Administer -> Commincations -> FROM Email Addresses

"name" info@example.org - set this in the same format to your email id and update - and try first if you are getting error try the below option

If that didn't help please try using an gmail account email ID rather than .org ID - that should work correctly - I guess

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.