1

Weirdness I can't find answer to. I hope I can articulate this well enough. If not, I'll make a screencast. And is not the same as Contribution page "other amount" option causes weird behavior - possible bug?

Steps:

  1. Create Contribution Page
  2. Set contributions for only "Other Amount". No other entries for contributions.
  3. Set for Membership signup
  4. Tick "Separate Membership Payment"
  5. Test Drive choosing a membership level (type) and leaving "Other Amount" blank is successful through end of workflow with correct amount for Membership showing only.
  6. PROBLEM: (Test) Receipt sent by email shows correct amount for Membership but also includes same for 'Other Amount' doubling the total.

Then if I untick "Separate Membership Payment" then the correct amount appears through the workflow but then two receipts are sent; one for Contribution and one for Membership. But, the Membership receipt continues to fill in the "Other Amount" section with the Membership amount and doubles the total amount.

1

That definitely sounds like a bug. It's not really replicable on the demo server, because you can't get emailed receipts, but if you can replicate this on a site built with buildkit, you can file this at https://issues.civicrm.org.

To start tracking the bug down, I'd insert the {debug} Smarty token into your receipt. Hopefully there's an obviously wrong variable.

  • Jon, I entered in working SMTP and seems that the demo site is not acting this way but the Joomla demo site is not the current version or of CiviCRM either. Gonna try it on the Drupal site but not sure this is a good comparison. – BruceW Dec 1 '16 at 0:24
  • Can't get Smarty Console to work placing token {debug} in receipt. All the output is in the metadata but the console doesn't appear. Ideas? – BruceW Dec 1 '16 at 2:34
  • @BruceW The Smarty Console (I assume you mean using &smartyDebug=1) isn't applicable to message templates. That only shows the Smarty for web pages - in your case, that's probably the "Message Templates" page. The {debug} tag is necessary because it will inject that info into an email. If you send yourself a test message with the {debug} token inserted you should get useful debugging info in the receipt you receive. – Jon G - Megaphone Tech Dec 2 '16 at 18:09
0

This appears to be the bug described in CRM-19298. A patch has been submitted in the last couple of days, but it's not yet in the review queue for the January release. If you have the ability to provide QA, please update the Jira ticket!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.