0

We have created some custom fields/profiles to use with certain CiviEvent registrations. These profiles only display in the event registration when they are selected in the event setup - as expected. However, these profiles appear in the confirmation email despite not being selected for use in the registration. See image below - the highlighted area shows the proflies/custom fields that should NOT appear because they were not used in the event creation. How do I stop them being sent with the confirmation when they are not used?

CiviEvent confirmation email

Thanks, Eric CiviCRM 5.4.1 WP 4.9.8

  • This are send from online or offline registration? – Pradeep Nayak Sep 4 '18 at 17:14
  • Online registration – Eric W Sep 4 '18 at 17:25
0

Eric, Disabling those fields should remove them from the confirmation email. If you can't disable them (maybe they are from another active event), you can edit the Event Registration Confirmation and Receipt message and target the Event using $event.id (as in {if $event.id != "40"}do such and such{/if} ). Administer > CiviMail > Message Templates - System Workflow Messages Good luck!

0

To tag on to Greg's response: if disabling the fields and/or modifying the Smarty receipt template won't work for you, check to ensure that the data sets in which those fields reside are specific to the types of events for which you want to use them. I've seen a lot of clients over the years set up participant fields for all events and then get frustrated later because they 1) appear in emails and 2) make back-end registration a bit of a pain.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.