I installed CiViCRM on WordPress and imported a Drupal CiViCRM database into it. everything seemed to work well. Just that I'm getting few errors such as Unknown extension: org.civicoop.civirules. Error loading module file (). Please restore the file or disable the module

I want to fix those errors. I wanted to access the extension option under administer>System settings but can't find the option to add or remove extensions. Hope you could help me fix this issue. I am using CiviCRM 4.7.27 on WordPress

Thank you


2 Answers 2


The extensions need code files that are not in your database, but your imported database will have a table called civicrm_extension with a list of the installed extensions.

So it will expect every extension in that table to be present (code files) in the correct spot. Obviously that is not the case. You need to either re-install these extensions OR also copy the extension directory from your source installation. Does that make sense?


From the information you've given, it sounds like you should simply need to re-install the Civirules extension from scratch.

Administer > System Settings > Extensions

From the extensions page, select Add New to find the list of available but not yet downloaded extensions, you can sort them alphabetically by clicking "Extension Name (Key)". Then find Civirules and click Download.

enter image description here

Civirules should now be in your downloaded Extensions, and if not already enabled should give you an option to Install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.