3

I posted about this earlier here: "Loading Failed" when soft crediting to a Personal Campaign Page

And Coleman kindly submitted a fix for it: https://github.com/civicrm/civicrm-core/pull/6156

Trouble is, I was never able to get the fix to work on my end and when I check the Demo site, which is now 4.6.6, it also still fails when you try to add a PCP page.

If I edit an existing donation from either a contact's card or by searching for a contribution and use the PCP drop down and try to search for a PCP -the screen below appears. I also tried opening the contribution in a new tab (rather than the overlay edit) and got the same error. I get the same error if I try to enter a check donation from scratch and add a PCP credit.

enter image description here

Did I miss something in the fix or is it not really working!?

4
  • Could you edit your question with exact steps to reproduce this bug? I haven't been able to get the "Loading failed" message.
    – Coleman
    Jul 22, 2015 at 18:43
  • Hmm, I edited the question, hope I was specific enough! I also tried multiple browsers with the same result.
    – RayWright
    Jul 22, 2015 at 19:26
  • I did some further testing on the demo sites (as I just discovered the development sandboxes.) WordPress Civi 4.5.9 PCP crediting works. Drupal 4.5.9 PCP crediting works. But WordPress 4.6.6 PCP crediting results in 'loading failed'. Drupal 4.6.6 PCP crediting works. (The only Joomla demo I saw was 4.6.0 but didn't have PCP as a credit option at all.)
    – RayWright
    Jul 29, 2015 at 19:53
  • the 4.5 series is no longer supported so that's not an issue. Sounds like in 4.6 it is working in Drupal but not WP... I hadn't tested there.
    – Coleman
    Jul 29, 2015 at 20:14

1 Answer 1

3

I finally figured it out: when you checked it on the WP demo site vs Drupal it turns out there was a conflict between a wp url param and one used by the widget.

This fixes it: https://github.com/civicrm/civicrm-core/pull/6351

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.