0

Unable to upgrade Mosaico Extension. I keep getting an error that I need to upgrade Afform from Civicrm.org. (See picture.) I can't find Afform within the extension browser within civicrm, and either way it is already in my file manager and showing to be installed.

I'm attaching the error message that happens when trying to download and install the extension within Civicrm.

screenshot error

5
  • 1
    i have seen some comments previously about issues if Afform (or was it SearchKit) was enabled when it was a non-core extension, but now it is a core extension and perhaps that be an issue to investigate. eg this one but it relates to searchkit civicrm.stackexchange.com/questions/41068/…
    – petednz - fuzion
    Feb 26, 2022 at 21:28
  • 1
    Yes that sounds possible. Or maybe it's just a label vs name thing - if you are looking for "afform" in the UI extension browser you won't find it because it's called Form Core there. I don't know what version you're on but that disconnect was improved in version 5.44 via github.com/civicrm/civicrm-core/pull/21852
    – Demerit
    Feb 26, 2022 at 22:11
  • Thank you! That fixed it. I had to upgrade "Form" core component. I kept looking for Afform. Silly me! Thanks folks!
    – Lester
    Feb 28, 2022 at 19:17
  • 1
    If your problem is solved, please write up the solution as an answer. It's easier for others to read an answer than track through comments.
    – Aidan
    Mar 7, 2022 at 13:04
  • My apologies Aidan. I've added the answer, which was given by Demerit. Thanks!
    – Lester
    Mar 9, 2022 at 15:56

1 Answer 1

2

As Demerit mentioned, I was looking for the name "Afform" and it is now called "Form Core." The error kept throwing me off asking for the extension "afform." I upgraded the extension Form Core and now everything is working well. Thank you for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.