2

This is an old topic but still a good one. It seems that it moved a bit in the messaging environment and that one can actually communicate through third-part services with Whatsapp: Waboxapp Whatsmate Whatsapp Business


2

@logan Bear i would recommend you upgrade to 5.19.1 It has just come out and should include this PR https://github.com/civicrm/civicrm-core/pull/15779 which should resolve your issue


2

I believe this is fixed with https://github.com/civicrm/civicrm-core/pull/15780. It will be hopefully included in a point release that should come out soon for 5.19


1

campaign_id is a field in the civicrm_mailing table in your database. I suspect that the only ways to modify this are - edit the db directly - use the API Explorer to change the value (via /civicrm/api#explorer) hopefully those are enough pointers for a start


1

With the help of the answer to How to disable or fix the wysiwyg editor on civimail I managed to get it to not strip links by adding this line to the config: config.extraAllowedContent = 'html;head;body;span;ul;li;table;td;style;a;a[*];*[id];*(*);*{*}'; It's different from the linked answer in that it explicitly reallows a and all its attributes. So while ...


1

You didn't mention the path to the config.js that you're editing, which I think will help people answer your question. However, my guess is that you are installing Civi using the Roundearth plugin, because that would account for you having two different config.js files. I'm also guessing you're editing the file at <projectroot>/vendor/civicrm/civicrm-...


1

Turns out this was caused by some server settings by my hosting provider (apparently they did some changes to the firewall). They managed to fix it and it seems to be working fine.


1

Both answers above have been very useful, but I have found out a bit more. If you use the edit message templates permission to show the Message Templates menu item, then it still allows the editing (but not deleting and disabling) of the System Workflow Messages even if edit system workflow message templates permission is nitset. I don;t want to allow this ...


Only top voted, non community-wiki answers of a minimum length are eligible